unable to import the mysql data into database


I am using mysql 5.0 version   i want to import data  into mysql database . when i am importing the data  i am getting an error

ERROR 1115 (42000) at line 17: Unknown character set: ‘utf8mb4’

How to resolve this issue ?

jessicalola Supporter Asked on October 10, 2016 in Programmer.
Add Comment
1 Answer(s)

This issue may be resolved by upgrading your MySQL version.

To see the present version which is installed in your system.

see the version

[root@localhost]# rpm -qa | grep mysql

Install and activate the REMI and EPEL RPM Repositories

[root@localhost]# wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.rpm && rpm -Uvh epel-release-latest-6.noarch.rpm

[root@localhost]# wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm && rpm -Uvh remi-release-6*.rpm

To to enable the REMI repository globally:

[root@localhost]# vi /etc/yum.repos.d/remi.repo

under remi section change enables=0 to enabled 1

save and exit.

update and mysql 5.x to latest

[root@localhost]# yum -y update mysql*

[root@localhost]# rpm -qa | grep mysql

you can see it will updated to 5.5

Addisonjack Supporter Answered on October 10, 2016.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.